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Model Objective: 1 

The objective of the Urban Tree Risk Index model (UTRI) is to prioritize street segments of a community for more 2 

detailed (comprehensive or intense) risk assessment, mitigation, and management.  In addition, the UTRI and 3 

resulting urban tree risk management is a critical component in the Vegetation Risk Management Plan. 4 

Model Overview: 5 

CARPDC has developed a relatively simple GIS approach to rank areas of the community for their likely risk to 6 

infrastructure and human life in the event of a natural disaster (e.g. hurricanes, ice storms, straight-line winds) 7 

based on the publication Urban Tree Risk Management: A Community Guide to Program Design
1
. 8 

The Urban Tree Risk Management guide outlines a process for prioritizing, assessing, and mitigating tree risk in 9 

urban areas.  Its principal underlying concept is the “tree risk zone” that guides urban forest managers to those 10 

areas of greatest concern when resources are limited.  The CARPDC Urban Tree Risk Index (UTRI) tool is used to 11 

identify and prioritize street segments as “tree risk zones” that provide the prioritization framework for planning, 12 

assessment, mitigation, and response to natural disasters.  The UTRI is the basic driver for the Vegetative Risk 13 

Management Plan which includes collaborative strategies, the tree risk map, street segment (tree risk zone) field 14 

verification forms to guide detailed assessment, pre- and post-disaster mitigation, debris estimation, and disaster 15 

response. 16 

The methodology (GIS model) and resulting ranking is a “springboard” for state, regional and local collaboration of 17 

community leaders, emergency managers, regional and local planners, community staff, and the urban forestry 18 

profession. 19 

The UTRI model supports the “Collection Strategy” prioritization outlined in the Public Assistance Debris 20 

Management Guide (FEMA 325, July 2007). 21 

In addition, UTRI supports key concepts of the National Disaster Recovery Framework
2
: 22 

 local government has the primary role of planning and managing all aspects of the community’s recovery, 23 

 the ability of a community to accelerate the recovery process “beginning” with its efforts in pre-disaster 24 

preparedness, mitigation and recovery capacity building, 25 

 an impacted community assumes the leadership in developing recovery priorities and activities that are 26 

realistic, well-planned and clearly communicated. 27 

GIS Approach: 28 

As developed within GIS the Urban Tree Risk Index (UTRI) becomes a powerful tool at the state and regional level 29 

for long-term disaster planning, and at the regional and local levels for planning, mitigation, response, and 30 

recovery. 31 

Tree risk is associated with: targets (infrastructure or human), trees and their structural characteristics, and an 32 

evaluation of failure probability.  UTRI does not look at individual trees, but at the spatial distribution of high 33 

priority but vulnerable community infrastructure, human population, and tree distribution (based on tree canopy) 34 

to guide planning, prioritized assessment, and mitigation by urban forest and emergency managers. 35 

UTRI uses a street segment as the smallest risk zone element for analysis.  A street segment is the portion of a 36 

street between two intersections, or from an intersection to the end of that street.  Within any area being 37 

analyzed, the street segment length may vary considerably.  However, these street segments are typically shorter 38 

and more uniform (i.e. less variability) in urbanized areas where disaster effects are greatest for people and 39 

infrastructure (i.e. street network density is typically related to non-street infrastructure which is related to 40 

                                                      
1 Jill D. Pokorny (Coordinating Author), USDA Forest Service, Northeastern Area, State and Private Forestry, 1992 Folwell Ave, St. Paul, MN 
55108, NA-TP-03-03, 2003, 194 pages. 
2 National Disaster Recovery Framework: Strengthening Disaster Recovery for the Nation, Department of Homeland Security (DHS), Federal 
Emergency Management Agency (FEMA), Washington DC, September 2011, 116 pages. 
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population density during the daytime and/or nighttime; the assumption here is that as the built environment 41 

intensifies, then there are probably more people). 42 

The UTRI implementation of “tree risk zones” helps: 43 

1. develop Debris Management Plans and Hazard Mitigation Plans 44 

2. identify areas for block-level or individual tree risk assessment 45 

3. guide local risk management and pre-storm mitigation (pruning and removal) 46 

4. create non-threatening tree planting projects (proper species and site evaluation) 47 

5. stratify a debris estimation sample 48 

6. prioritize disaster response 49 

GIS Data: Sources: 50 

The most accurate and current GIS data should be obtained.  Possible sources include: 51 

 Municipal planning and GIS agencies Examples: facilities, boundaries 52 

 Municipal urban forest management Examples: tree canopy, tree risk management 53 

 County EM and planning agencies Examples: facilities, imagery 54 

 Regional planning agencies Examples: transportation, imagery 55 

 State agencies (EM, DOT) Examples: transportation, facilities 56 

 Department of Homeland Security Examples: HSIP Gold including facilities, population 57 

 US Census Examples: population, other TIGER lines 58 

 USDA Farm Service Agency (FSA) Examples: NAIP 1 meter imagery 59 

 US DOI, Geological Survey Examples: MRLC 30 meter tree canopy 60 

GIS Data: Assembly: 61 

For the area of interest (AOI), the GIS data needed to develop the tree risk rating and calculate the priority index 62 

that supports the Vegetation Risk Management Plan includes the following spatial layers: 63 

1. county and municipal boundaries 64 

2. street and highway infrastructure 65 

3. community infrastructure most important during disaster response (e.g. hospitals, EM, police, fire, water 66 

supply, and water treatment) 67 

4. population density 68 

5. tree canopy 69 

Within the GIS methodology developed, each of these UTRI components is converted to a GIS raster layer(s) with a 70 

rating that reflects component importance or level of concern.  The resolution of the rating can vary depending on 71 

the availability of GIS data.  In the Autauga and Elmore County (Alabama) prototypes, 30 meter pixels were used. 72 

The UTRI represents the important relationships that exist among these GIS layers relative to disaster planning, 73 

response, and recovery (short-term and long-term). 74 

For example, storm damaged trees can: 75 

 directly injure or damage… 76 

 people 77 

 facilities (e.g. buildings, bridges) 78 

 block emergency access to… 79 

 injured people 80 

 emergency facilities (e.g. EM, public safety, hospitals, shelters) 81 



Local Disaster Planning, Mitigation, Response, and Recovery December 13, 2012 
Urban Tree Risk Index (UTRI) v 1.09a 

GIS Data Preparation and Processing  Page: 3 
CARPDC, Montgomery, Alabama 
 C:\Documents and Settings\dhartel\My Documents\Dropbox\Forest Service\UTRI-CARPDC\Documents\2012 UTRI Data Process and GIS Tool Description (13Dec12 v1.09TableRevisionUpdate).docx 

 disrupt… 82 

 communication 83 

 energy 84 

 water supply and treatment 85 

 food supply 86 

 affect… 87 

 debris generation (i.e. quantity) 88 

 debris handling (i.e. number and locations of debris sites) 89 

 the “flow” of environmental services from tree canopy (i.e. temporary or permanent 90 

losses/reductions in stormwater, shade (energy), PM10 capture, and visual or noise buffers) 91 

GIS Data: Preparation: 92 

Assignment of priority ratings within each layer are dependent on the layers attribute properties and the 93 

regional/local disaster perspective.  The scale of the UTRI analysis (that is, the area of interest) has a bearing on 94 

assignment of individual layer ratings that are “summed” into the final UTRI risk index.  For example, if developing 95 

a UTRI for a municipality, regional health care and the transportation corridors to reach those regional care 96 

facilities may not be as important if the community has local facilities (i.e. emergency care options) of sufficient 97 

size and capability for the planned event. 98 

GIS Data Overlay Relationships: 99 

 
 

Street Risk 

People Risk 

Facilities Risk 

Tree Risk 

UTRI 
(by street segment) 
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Process Step Data Source GIS
3
/Model Processing

4
 Model Tools Data Layer(s)

5
 Input Attribute Output Attribute Assignment or Reclass Model Notes GIS Processing Notes (As Built) 

1 Assemble data layers needed 
(see Data Source column for 

steps -). 

Create a folder & subfolders 
for the project; for example: 

…\UTRI2012Elmore 
…\UTRI2012Elmore\So
urceData 
…\UTRI2012Elmore\M
aps 
…\UTRI2012Elmore\Do
cuments). 

See below in this 
column and Notes 
column links. 

NA NA NA NA NA NA http://www.census.gov 

http://www.mrlc.gov 

https://www.hifldwg.org 

Other local/regional/state sources 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

2 Create an ArcMap 
personal/file geodatabase 
and map document (i.e. 
project) in the project “root” 
folder from the previous 
step. 

Set the default geodatabase. 

NA ArcCatalog 

 Create/select folder 

File=>New Personal Geodatabase 

ProjectNameDate 

ArcMap 

File New… 

Dialog=>Default geodatabase 

NA NA NA NA NA The geodatabase is an excellent file/layer organizational tool 
and may also function as process documentation.  It should 
hold all intermediate layers used in the processing as well as 
the final vector and raster layers. 

An example ProjectNameDate might be: 

UTRI2012Elmore.mdb 

The original supporting data (e.g. NLCD or Census) does not 
have to be placed into the geodatabase. 

Set projection and datum for the geodatabase and then make 
it the ‘default’ geodatabase when you create your map 
document (i.e. the mxd; the ‘project’). 

Note: Users may opt to use ArcGIS shapefiles and stand-alone 
raster files if desired.  Layer name may be used as the 
shapefile and raster file names. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

3 Create project boundary; i.e. 
the area of interest (AOI) 

2010 Census 
TIGER Lines -  
Geographic 
Areas=>Counties 
(and equivalent) 

Data Download 

 Census data or other 

UTRI Model 

 Select feature (AOI) 
 Extract AOI feature 
 Buffer to 1k or desired distance 
 Project to project coordinates 

ArcMap 

TB=>Select Feature (e.g. County) 

RC=>Data=>Export Data 

ArcToolbox 

Analysis Tools=>Proximity=>Buffer 

02_UTRI-AOI AOI_Region 
AOI_County 
AOI_City 
AOI_Other 

NA NA NA Source: http://www.census.gov/cgi-
bin/geo/shapefiles2010/main. 

Use UTRI model tool or ArcToolbox. 

This step may include multiple levels (e.g. county, 
municipality, neighborhood). 

Intermediate layer names should lead to or reflect the final 
layer to be used by UTRI; e.g. 

AOI_CountyCensus (i.e. first data export layer) 

AOI_County (i.e. after projection and datum set) 

AOI_County1k (e.g. 1 kilometer buffer) 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

4 Process streets (Targets) 2010 Census 
TIGER Lines  - 
Features => All 
Lines (i.e. 
“edges”) 

or… 

Features => Roads 
=>All 

Data Download 

 Census data or other 

UTRI Model 

 Add UTRI_T (set to 0) 
 Clip with AOI 
 Project to project coordinates 
 Classify 
 Buffer to right-of-way (ROW) extent 

ArcToolbox 

 Convert to raster at project 
resolution 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

03_UTRI-Street 

03_UTRI-Blocks 

AOI_Street 

vStreet 

rStreet 

MTFCC UTRI_S to raster 
cell 

UTRI_S & Cell: 

S1100 = 4 

S1200 = 3 

S1300/S1400 = 2 

Others important to 
your community = 1 

All else = 0 

Source: http://www.census.gov/cgi-
bin/geo/shapefiles2010/main. 

UTRI_S is an integer value. (STREET) 

Use 50’ buffer from centerline or appropriate width based on 
street type for the segment or other local knowledge to create 
the polygon vector layer of street segments. 

Trees within the street buffer represent the area of concern 
for disaster planning if they can adversely affect people, 
facilities, or transportation. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

4a 
Process facilities (Targets) 

 

 

 

 

 

 

 

 

 

 

Local or 
HSIP Gold 

Data Download 

 Data as available 

UTRI Model 

 Add UTRI_F (set to zero) 
 Clip with AOI 
 Project to project coordinates 
 Classify 
 Buffer facility vicinity 

ArcToolbox 

 Convert to raster at project 
resolution 

04_UTRI-Facility AOI_Facility 

vFacility 

rFacility 

 

 

 

 

 

 

 

 

Name or 
description 

UTRI_F to raster 
cell 

 

 

 

 

 

 

 

 

 

UTRI_F & Cell: 

Hospitals=5 

Fire, Police, Emergency 
Management Center = 
4 

Communication 
Towers, Water 
Treatment Plants, 
Water Towers, Waste 
Water Treatment Plants 
= 3 

Schools, Parks, and 

Source: Local or HSIP CD. 

UTRI_F is an integer value. (FACILITY) 

Buffer the facilities with a 100 meter or 200 meter radius. 

This represents the “immediate area” of risk for each critical 
facility. 

 

 

 

 

 

 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

                                                      
3
 ArcGIS is ArcCatalog, ArcMap, ArcToolbox, and ArcGIS Extensions; TB refers to ArcMap menu tools & toolbars; ATB refers to the ArcToolbox, TOC is the ArcMap table of contents, RC is ‘right-mouse click’; Dialog is the input dialog window from a menu selection (e.g. New…). 

4
 “=>” Indicates ArcGIS  menu selections. 

5
 Suggested layer names; AOI is area of interest and used for clipping. Some steps will have multiple layers; use v prefix for vector and r prefix for raster in those cases (e.g. vStreet and rStreet represent the same data). 

http://www.census.gov/
http://www.mrlc.gov/
https://www.hifldwg.org/
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
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Process Step Data Source GIS
3
/Model Processing

4
 Model Tools Data Layer(s)

5
 Input Attribute Output Attribute Assignment or Reclass Model Notes GIS Processing Notes (As Built) 

 

 

 

 

Process facilities  

(for Step 4b that follows) 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

 

 

 

Data Download 

 Data as available 

UTRI Model 

 NA 

ArcToolbox 

ATB=>Analysis 
Tools=>Proximity=>Buffer 

 

 

 

 

vFacilityZone 

 

 

 

 

UTRI_F 

other locations where 
people congregate = 2 

Others important to 
your community = 1 

All else = 0 

 

 

 

 

UTRI_F is an integer value as assigned in vFacility. 

Selected critical facilities (e.g. use two highest UTRI_F levels) 
should be buffered to a distance of 3000 meters to 5000 
meters and used in the next step that identifies critical routes 
for these facilities in the AOI. 

4b Process streets (Access to 
Facilities) 

2010 Census 
TIGER Lines  -  

Features => Roads 
=> 
Primary/Secondar
y 

vFacilityZone 

Data Download 

 Data as available 

UTRI Model 

 Add UTRI_C (set to zero) 

ArcMap Tools 

 Cumulative UTRI_F into UTRI_C 

RC=>[TOC Layer] Open Attribute Table  

TB=>Selection=>Select by attribute 

TB=>Selection=>Select by location 

RC=>[Attribute Name] Field Calculator 

ArcToolbox 

 Convert to raster at project 
resolution 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

NA vCFstreet 

rCFstreet 

UTRI_F UTRI_A to raster 
cell 

Cumulative UTRI_A from 
the critical facility zones 
layer. 

UTRI_A is an integer value. (ACCESS) 

This will be the GIS layer of primary roads in the AOI; assigned 
the risk ratings for all facilities that depend on that particular 
street or street segment; segment risk is cumulative for all 
critical facilities (CF) in vFacilityZone. 

When making calculations for street segment rating for facility 
access: 

work alternatively in two layers: vFacilityZones, vCF_Streets 

set all UTRI_C to one (1) in v_CF_Streets 

use a “Select by Attributes…” for UTRI_F > x (rating desired) 

calculate UTRI_C = UTRI_C + x 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

5 Process population (Targets) 2010 Census or 
HSIP LANDSCAN 

Data Download 

 Census data or other 

UTRI Model 

 Extract population in AOI 
 Convert to vector (polygon) 
 Project to project coordinates 
 Calculate square miles (=acres/640; 

=square feet/27878400; =square 
meters/2589988) 

 Calculate population/square mile 
 Reclassify 

ArcToolbox 

 Convert to raster at project 
resolution 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

05_UTRI-Census vCensus 

rCensus 

 SqMiles 

Pop_SqMile 

UTRI_P to raster 
cell 

Classification- Try 
Quantile, Natural Breaks 
(Jenks) or other symbol 
classification technique 
with four or five classes. 

UTRI_P & Cell: 

Class 5 = 4 

Class 4 = 3 

Class 3 = 2 

Class 2 = 1 

Class 1 = 0 

Source: http://www.census.gov/cgi-
bin/geo/shapefiles2010/main. 

Source: Local or HSIP CD. 

UTRI_P is an integer value. (POPULATION) 

When making calculations for population density: 

set all Pop_SqMile to zero (0) 

use a “Select by Attributes…” for areas > 0 (square miles) 

calculate Pop_SqMile = Population/SqMiles 

Areas with zero population / square mile should be set to 
UTRI_P = 0. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

6 

 
 
 
 
 

Process tree canopy 
(Potential Tree Failure) 

NLCD (USGS) 

NAIP (FSA) 

Data Download 

 Most current NLCD tree canopy 
 Or, local tree canopy 
 Or, classify most recent NAIP 

UTRI Model (NLCD) 

 Clip to buffered AOI 
 Reclassify (raster operation) 
 Project to project coordinates 

ArcToolbox 

ATB=>Data Management 
Tools=>Raster=>Raster 
Processing=>Clip  

ATB=>Data Management 
Tools=>Projections and 
ATB=>Transformations=>Raster=>Proj
ect Raster 

ATB=>Spatial Analyst 
Tools=>Reclass=>Reclassify 

06_UTRI-Canopy AOI_Canopy 

rCanopy 

Cell Value Cell value (UTRI_T) Classification- Try 
Quantile, Natural Breaks 
(Jenks) or other symbol 
classification technique 
to create from five or 
eleven classes. 

Cell (UTRI_T): 

91-100 = 10 

81-90 = 9 

71-80 = 8 

61-70 = 7 

51-60 = 6 

41-50 = 5 

31-40 = 4 

21-30 = 3 

11-20 = 2 

1-10 = 1 

0 = 0 

Tree canopy is available from the MRLC: 
http://www.mrlc.gov/index.php 

The National Land Cover Database (NLCD 2001) tree canopy 
layer is downloaded as a raster and the cell value represents 
percent of tree canopy (from 0 to 100%) for the 30 meter 
pixel. 

This is a single file for the entire coterminous US and is in the 
Albers projection and in meters, WGS84. 

The MRLC Consortium Viewer at: 
http://gisdata.usgs.gov/website/mrlc/viewer.htm 
can be used to download an area that includes a single or 
multiple counties (not by county boundary but by rectangular 
selection area that you estimate will include your AOI).  This 
raster file can then be clipped with the AOI. 

When downloading from the viewerthe default is to get the 
landcover dataset.  To specify tree canopy, click on the 
download tab (in the right panel), and uncheck landcover and 
select tree (forest) canopy). 

Then make your download area with the selection box tool (in 
the left panel near the bottom). 

ArcGIS Spatial Analyst Extension is required for most of the 
operations in this and the following steps. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

6a Area of Interest Mask vStreet Data Download 

 Streets from Step  

 vAOImask 

rAOImask 

Select any 
integer attribute 
with a value of 1 

Cell Assign value of 1 to the 
areas within the AOI that 
should have a risk index 

Use approximately 3x the distance used in Step 3; 150’ buffer 
from centerline or appropriate width based on street type for 
the segment or other local knowledge to create the polygon 

Input Layers: 
 

http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.census.gov/cgi-bin/geo/shapefiles2010/main
http://www.mrlc.gov/index.php
http://gisdata.usgs.gov/website/mrlc/viewer.htm
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Process Step Data Source GIS
3
/Model Processing

4
 Model Tools Data Layer(s)

5
 Input Attribute Output Attribute Assignment or Reclass Model Notes GIS Processing Notes (As Built) 

UTRI Model 

 Buffer to a distance that exceeds 
right-of-way (ROW) extent 

ArcToolbox 

 Convert to raster at project 
resolution 

ATB=>Conversion Tools=>To 
Raster=>Feature to Raster 

(or due field 
calculator to set 
it) 

calculated; otherwise 
NODATA. 

vector layer of street segments. 

When buffering, select “merge polygons”. 

This raster layer will be used to mask OUT all areas that are 
beyond the buffer. 

 
Output Layers: 

 

 

Other Comments: 

7 Create UTRI (Raster) rStreet 

rFacility 

rCFstreet 

rCensus 

rCanopy 

rAOImask 

Data Download 

 NA 

UTRI Model 

 Run model to sum individual layer 
cell values 

ArcToolbox 

ATB=>Spatial Analyst Tools=>Map 
Algebra=>Raster Calculator 

ATB=>Spatial Analyst 
Tools=>Reclass=>Reclassify 

07_UTRI-Index rUTRIsum 

rUTRI 

UTRI_S (cell) 

UTRI_F (cell) 

UTRI_A (cell) 

UTRI_P (cell) 

UTRI_T (cell) 

Cell Value Classification- Try 
Quantile, Natural Breaks 
(Jenks) or other symbol 
classification technique 
to create four or five 
classes. 

Once break points are 
determined use the 
raster reclassify tool to 
create a final reclassified 
raster layer. 

Reclassification of input layers may be performed to create 
more suitable risk index upon summation. 

Use ArcMap RC=>Properties->Symbology dialog to view the 
Jenks Natural Breaks to set and test breaks in the data prior to 
reclassification.  

The final rUTRI layer is created from the reclassification of this 
rUTRIsum into four classes: 1:Low, 2:Moderate, 3:High, and 
4:Very High. 

See Appendix D for Raster Calculator details for syntax and 
weighting of layers. 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

8 Create UTRI (Vector) rUTRI Data Download 

 NA 

UTRI Model 

 NA 

ArcToolbox 

 Convert UTRI raster to vector and 
assign UTRI risk rating to street 
segments for field verification and 
stratification components. 

ATB=>Conversion Tools=>From 
Raster=>Raster to Polygon 

and… 

ATB=>Analysis 
Tools=>Overlay=>Spatial Join 

or possibly… 

ATB=>Analysis 
Tools=>Overlay=>Identify 

or possibly… 

ATB=>Analysis Tools=>Overlay=>Union 

08_UTRI-R2V vUTRI NA Cell values summed 
to UTRI 

(grid_code) 

NA After conversion to a polygon layer, the original street layer 
(AOI_Street) is assigned the corresponding UTRI value 
(obtained in the conversion from raster).  A street segment 
may intersect from 1 to n raster cells that are summed into 
the final UTRI and assigned to the street layer. 

Note: Only integer raster layers can be converted to polygon 
features.  If you create a floating point rater in step 7 you will 
need to convert it to integer for this step (see Appendix D). 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

9 Create field verification 
report 

NA UTRI Model 

 NA 

ArcToolbox 

 Can use Crystal Reports, or read DBF 
in Excel or other spreadsheet to 
generate report 

NA  NA NA NA Generates street segment field verification form from street 
layer for urban forester.  Includes a color coded map(s) and 
corresponding list(s) of street segments keyed to map. 

Generates standard UTRI map from an ArcMap template. 

Updated street segment map (and list) after verification is 
used for: 

1. Comprehensive risk management (risk zones) 
2. Tree risk assessment and rating 
3. Pre-disaster mitigation 
4. Urban forest management (planting) 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

10 Produce a stratified random 
sample (street segments) for 
debris estimation in i-Tree 
Eco or i-Tree Streets. 

Produce UTRI street segment 
map. 

NA UTRI Model 

 NA 

ArcToolbox 

 NA 

Other Tools 

 Stratified Sampling Tools 

NA  NA NA NA Biogeography Branch’s Sampling Design Tool for ArcGIS 

http://ccma.nos.noaa.gov/products/biogeography/sampling/ 

or Hawth's Analysis Tools for ArcGIS v9.3 

http://www.spatialecology.com/htools/overview.php 

or the Geospatial Modeling Environment 

http://www.spatialecology.com/gme/ 
or Iowa State PM2082-09n Using Field Calculator: Create 
Random Values. 

www.extension.iastate.edu/Publications/PM2082-09N.pdf 

Input Layers: 
 
 
Output Layers: 

 

 

Other Comments: 

http://ccma.nos.noaa.gov/products/biogeography/sampling/
http://www.spatialecology.com/htools/overview.php
http://www.spatialecology.com/gme/
http://www.extension.iastate.edu/Publications/PM2082-09N.pdf
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Additional UTRI Model Processing Notes: 100 

GIS data source (and quality) will control the amount of editing needed prior to using the model and the quality 101 

and functionality of the model output (i.e. the risk index calculated, field forms, reports, and maps).  The notes 102 

below will provide some indication of the most important considerations when using the data and model.  Editing 103 

may also be influenced by data processing and reporting standards within your agency. 104 

Step 1: Assemble Data Layers Needed 105 

Obtain necessary layers (often as ERIS ArcGIS shapefiles) that will be needed in Steps 1-10 (AOI, streets, 106 

facilities, population, canopy).  Layers not required by the model may also be obtained and used to develop 107 

more familiar map products for reports and field use (e.g. adding a stream network gives field crews additional 108 

landscape reference points). 109 

The project resolution (size of the raster cells) will probably be controlled by the tree canopy layer which will be 110 

the only source data acquired that is a raster layer. 111 

Step 2: Create a Personal/File Geodatabase for the Project 112 

A well defined folder structure and geodatabase, while not required, will help organize your original data layers 113 

needed for the model and the intermediate and final layers needed to complete UTRI modeling. 114 

If a geodatabase is not used then you may also want to create a folder for “FinalModelLayers”. 115 

The “SourceData” folder may also have subfolders for the major modeling components: Boundaries, 116 

Transportation, Facilities, Canopy, and Others.  This is particularly helpful if significant editing and data 117 

manipulation is required prior to importing the data layer into the project geodatabase. 118 

Step 3: Create Project Boundary 119 

Input: Vector features needed to create the combined area of interest for the urban tree risk 120 

assessment. 121 

Output: A vector feature (polygon) that represents the AOI; it may or may not have an edge buffer. 122 

The UTRI Model, while originally intended for a county focus, may be used for any smaller or larger area of 123 

interest (AOI) desired.  Regardless of the spatial extent of your AOI the type of reporting should be determined 124 

at the beginning of the process (e.g. at the AOI or sub-AOI levels).  For example, if the AOI is a county but you 125 

also intend on reporting at the municipal level within the county then municipal boundaries will be needed at 126 

the reporting and map generation stages.  In addition, if those municipal boundaries cross county lines then 127 

adjacent county data (e.g. tree canopy, population, streets, facilities) will be need for the analysis. 128 

Once the final AOI boundary is determined a buffer may be desirable/useful particularly when modeling an 129 

area that is not based on political boundaries. 130 

Step 4: Process Streets (Targets) 131 

Input: Vector features (lines) representing public streets and roads. 132 

Output: A raster feature that represents the street right-of-way (ROW) with the cell values rated for risk 133 

(e.g. from 0-4) based on street type (MTFCC); UTRI_T is the vector layer attribute to use when 134 

creating the raster. 135 

Three types of Census TIGER/Line files are available for streets in shapefile format. 136 
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At the Census TIGER/Line website: use Features=>Roads. 137 

These include: “primary and secondary roads” and “all roads”.  Downloaded files have the file name 138 

structure like:  139 

 tl_2010_01_prisecroads.zip 140 

 tl_2010_01051_roads.zip 141 

These are typically 1:100000 scale derived centerlines (check the metadata). 142 

At the Census TIGER/Line website: use Features=>All. 143 

This will be the “edges” file that includes all lines for the county; streets can be created as a subset using 144 

the ROADFLG attribute (Menu=>Selection=>Select by attributes).   145 

Downloaded files have the file name structure like:  146 

 tl_2010_01051_edges.zip 147 

These are at a 1:24000 scale (check metadata) that have streets broken into smaller segments.  For 148 

example, in Elmore County (AL) the 1:24000 scale street file contains 12,000+ segments while the 149 

1:100000 street file contains only about 5,000 segments.  Either may be used for the UTRI modeling. 150 

The data structure of TIGER files may contain many attributes not needed for this model:  Recommended 151 

minimum requirements are unique street ID (not FID or OBJECTID), street name, road classification, and length.  152 

Ideally the street name should be the base name of the street including the type modifier as suffix (i.e. Street, 153 

Highway, Road, Boulevard, Circle, Court, etc. or their abbreviations); any direction prefix should be at the end 154 

of the name or in a unique attribute (e.g. “High St N” not “N. High St”).  The street name attributes may have to 155 

be manipulated into this format if desired. 156 

The “edges” file also contains the address range of the street segment.  The address ranges in these files 157 

(LFROMADD, LTOADD, RFROMADD, RTOADD) do not consistently have the lowest number (or highest) in the 158 

“from” component.  A more readable field report  form can be created if a new attribute is created (a text field) 159 

that assembles the block address range that consistently runs from smallest address to largest and that always 160 

looks at the right addresses (or left if there are no rights). 161 

This is the first of two GIS street layers needed for the UTRI model.   162 

1. all roads are needed to develop a risk prioritized street layer based on the type of road (using the 163 

attribute MTFCC or similar) 164 

2. primary and secondary street GIS layer that includes federal and state highways is used in the critical 165 

facility layer processing step 166 

For “all roads” (or “edges”) processing the street centerlines are buffered to a distance that will encompass any 167 

street-side trees that could affect the public ROW (right-of-way).  We currently use 50’ from the centerline for a 168 

combined buffered street width of 100’.  Other widths may be appropriate for your analysis and should be used 169 

as desired. 170 
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Step 4a: Process Facilities (Targets) 171 

Input: Vector features (points) representing critical facilities in the AOI. 172 

Output: A raster feature that represents the area of concern near the facility with the cell values rated for 173 

risk (e.g. from 0-4) based on facility type; UTRI_F is the vector layer attribute to use when 174 

creating the raster. 175 

The facilities will be represented in the UTRI model by two components: 176 

1. a simple circular zone (e.g. 100 meter or 200 meter radius) that accounts for the “immediate area” 177 

near the facility, and 178 

2. streets or street segments that support the facility (i.e. access to/from the facility) 179 

The first facility layer is a simple point buffer (e.g. 100 or 200 meters) with the type of facility rating reclassified 180 

and assigned to UTRI_F and converted to a raster layer. 181 

Note: If file errors occur for “Input Features” in the Feature to Raster (or Polygon to 182 

Feature) dialog try using the folder selection icon and select the vector (polygon) file 183 

from the geodatabase (or list of shapefiles). 184 

Input: Vector features (points) representing critical facilities in the AOI. 185 

Output: A vector feature (polygons) that will encompass primary and secondary roads of importance for 186 

this facility; carries the UTRI_F from the facility. 187 

The second facility layer (used in step 4b that follows) is a larger buffer on the highest ranked facilities (e.g. the 188 

top two facility rating classes) that will be used to select access routes to and from these facilities.  For this 189 

buffer use 3000 meters to 5000 meters.  Use the same UTRI_F value assigned in the “immediate area” buffer.  190 

This is the Facility Zone layer (e.g. vFacilityZone) and does not have to be converted to a raster. 191 

Step 4b: Process Streets (Access to Facilities) 192 

Input: A vector feature (polygons) that will encompass primary and secondary roads of importance for 193 

this facility; carries the UTRI_F from the facility; from 4a. 194 

Output: A raster feature that represents the street right-of-way (ROW) with the cell values rated for risk 195 

(e.g. from 1-n) based on cumulative UTRI_F of all facilities that depend on the particular street or 196 

street segment; UTRI_C is the vector layer attribute to use when creating the raster. 197 

This is the second of two GIS street layers needed for the UTRI model.   198 

1. all roads are needed to develop a risk prioritized street layer based on the type of road (using the 199 

attribute MTFCC or similar) 200 

2. primary and secondary street GIS layer that includes federal and state highways is used in the critical 201 

facility layer processing step 202 

For “primary and secondary” processing the street segments are spatially selected using the facility zones and 203 

the facility risk ratings (UTRI_F) are cumulatively assigned to UTRI_C.  This creates a second street layer that 204 

represents the overall importance (or risk) that specific streets have for access to and from facilities.  This layer 205 

is converted to a raster. 206 
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Step 5: Process Population (Targets) 207 

Input: A population layer (feature); may be either vector (e.g. Census blocks) or raster (e.g. LandScan). 208 

Output: A population raster layer with the cell values rated for risk (e.g. from 0-4) based on population 209 

density (e.g. population/square mile; UTRI_P is the vector layer attribute to use when creating 210 

the raster. 211 

This step begins with either a Census polygon or LandScan raster.  Data manipulation is done in a vector layer 212 

(polygon) so raster to vector conversion may be necessary to being (projection and datum may be set at that 213 

time). 214 

Note: If converting an input population raster to a polygon feature do NOT “simplify 215 

polygons” (i.e. leave that optional box in the conversion dialog unchecked). 216 

Other ArcGIS extensions (like XTools) can be used to calculate area in square miles. 217 

Note: If using the attribute table’s “Field Calculator” to calculate population/square 218 

mile, a “Select by Attribute…” should be made for areas > 0 square miles to avoid a 219 

“divide by zero” error. 220 

The natural breaks facility in RC: Properties=>Symbology can be used to help visually set the classification 221 

breaks for the reclassification. 222 

Step 6: Process tree canopy (Potential Tree Failure) 223 

Input: A raster layer that has cell values for percent tree canopy or (on higher resolution urban tree 224 

canopy (UTC) layers the landcover (e.g. water, canopy, impervious, bare soil, and grass). 225 

Output: A tree canopy raster layer with the cell values rated for risk (e.g. from 0-4) based on canopy 226 

density. 227 

If using NAIP or other imagery use or convert to project resolution during classification. 228 

When clipping raster layers from within ArcMap and using Data Management Tools=>Raster=>Raster 229 

Processing=>Clip check () the “Use input features” to clip with AOI boundary. 230 

Step 6a: Create AOI Mask 231 

Input: Vector features (lines) representing public streets and roads in Step 3. 232 

Output: A raster layer that will be used to “mask out” areas of the AOI of no interest (e.g. areas that are 233 

not near streets or public facilities.  The cell values are set to 1 and areas of no interest are set to 234 

NODATA. 235 

Create a vector (polygon) layer by buffering the street centerline from Step 3.  The buffer should exceed the 236 

buffer used to create vStreet and rStreet and is approximately 3x the distance (e.g. 150’) from the centerline. 237 

[combine polys; then set 1 attrib to value of 1] 238 

This raster layer will be used to mask OUT all areas that are beyond this buffer. 239 
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Step 7: Create UTRI Layer (Raster) 240 

Input: Raster layers: rStreet, rFacility, rCFstreet, rPopulation, rCanopy, rAOImask 241 

Output: An intermediate raster layer (rUTRIsum) that sums the input layers and a final raster layer (rUTRI) 242 

that is reclassified into four classes that correspond to risk zones in Urban Tree Risk 243 

Management: A Community Guide to Program Design. 244 

Step 8: Create UTRI Layer (Vector) 245 

Input: rUTRI 246 

Output: A vector (polygon) layer (e.g. vUTRI) that can be used to update the street layer with the UTRI for 247 

the segment.  Or combine the segment UTRI value with the street segment in some fashion. 248 

The conversion to a polygon is simply TB=>Conversion Tools=>From Raster=>Raster to Polygon.  Various GIS 249 

methods may be used to accomplish this final task that produces the layer used for the map and field report 250 

that includes both UTRI and the unique segment identification. 251 

Step 9: Create Field Verification Report 252 

Input: vUTRI or vStreet (updated with UTRI) 253 

Output: A listing of the street segments sorted alphabetically by street and in descending order of UTRI.  254 

Unique segment indices are used on corresponding map for field checks. 255 

This can be accomplished through the attribute table for the layer and Reports=>Create report. 256 

Step 10: Produce a Stratified Random Sample for Debris Estimation 257 

Input: vUTRI or vStreet (updated with UTRI) 258 

Output: A list of the street segments (plots) randomly selected by strata. 259 

Various GIS methods may be used to accomplish this task that randomly selects street segments (as plots) for 260 

debris estimation samples.  Each UTRI value (1 through 4) is treated as strata.  Plots selected should be 261 

approximately: 262 

 UTRI 4: 40% 263 

 UTRI 3: 30% 264 

 UTRI 2: 20% 265 

 UTRI 1: 10% 266 

The final street segment layer (e.g vUTRI or vStreet) that contain the UTRI can be modified to add an attribute 267 

RANDSEL and in the field calculator fill each record using the function: Rnd.  Generate randm numbers for each 268 

strata between 0 and 1.  Then, for example, if you are interested in 20% of the segments in that stratum, 269 

merely take all segments with a random number ≤ 0.2. 270 
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ArcGIS Raster Calculator & NODATA Values: 271 

Raster layers (i.e. ESRI GRIDS) may be created for streets, facilities, facility access, population, and canopy with 272 

NODATA cell values (i.e. null values NOT zeroes).  In the final step of the UTRI model, where the raster layers are 273 

summed, the following or similar syntax
6
 should be used

7
: 274 

with a layer weighting factor… 275 

(Con(IsNull("LAYER1"),0,"LAYER1") * 1.0)+\ 276 

(Con(IsNull("LAYER2"),0,"LAYER2") * 1.0)+\ 277 

(Con(IsNull("LAYER3"),0,"LAYER3") * 1.0)+\ 278 

(Con(IsNull("LAYER4"),0,"LAYER4") * 1.0)+\ 279 

(Con(IsNull("LAYER5"),0,"LAYER5") * 1.0)+\ 280 

(Con(IsNull("AOIMASK"),"AOIMASK",0)) 281 

without a layer weighting factor… 282 

Con(IsNull("LAYER1"),0,"LAYER1") +\` 283 

Con(IsNull("LAYER2"),0,"LAYER2") +\ 284 

Con(IsNull("LAYER3"),0,"LAYER3") +\ 285 

Con(IsNull("LAYER4"),0,"LAYER4") +\ 286 

Con(IsNull("LAYER5"),0,"LAYER5") +\ 287 

Con(IsNull("AOIMASK"),"AOIMASK",0) 288 

The “IsNull” function evaluates each raster cell and returns a “true” (i.e. value of 1) if the cell is NODATA. 289 

The “Con” function is a conditional statement that substitutes a zero (0) if the cell is currently NODATA, otherwise it 290 

uses the value found. 291 

AOIMASK is a raster layer that has a cell value of one (1) only in the area that you would like to evaluate for the final 292 

risk layer (e.g. rUTRI).  The conditional statement with this layer is reversed so that NODATA values remain and 293 

other values are replaced with zero (0) so that the mask does not affect the cumulative result (i.e. only the layers 294 

for: streets, facilities, access to facilities, population, and canopy contribute values for summation). 295 

The desired code above may be copied and pasted into the raster calculator; then change the “LAYERn” names 296 

appropriately for your project. 297 

  

                                                      
6
 Function names ARE case sensitive. 

7
 The back slash character “\” is the line continuation indicator. 
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During the summation into the final combined layer (i.e. rUTRI) the layers may optionally be weighted by 298 

modifying the component “* 1.0”. For example, use “* 2.0” to make a layer 2x its calculated weight, or “* 0.5” to 299 

make it ½ the calculated weight. 300 

Actual example with layer names substituted and no weighting: 301 

Int( \ 302 

(Con(IsNull("rElmoreTallassee_Streets_2"),0,"rElmoreTallassee_Streets_2") * 1.0) + \ 303 

(Con(IsNull("rElmoreFacilities200m_2"),0,"rElmoreFacilities200m_2") * 1.0) + \ 304 

(Con(IsNull("rElmoreTallassee_CFS_ZoneArea_2"),0,"rElmoreTallassee_CFS_ZoneArea_2") * 1.0) + \ 305 

(Con(IsNull("rLandScan2009UTM16N"),0,"rLandScan2009UTM16N") * 1.0) + \ 306 

(Con(IsNull("rCanopyRC2"),0,"rCanopyRC2") * 1.0) + \ 307 

(Con(IsNull(“rAOImask50m”), “rAOImask50m”,0)) \ 308 

+ 0.5) 309 

Integer and Floating Point (i.e. Real) Raster layers: 310 

The raster layer resulting from a calculation using real number weighting factors will be a floating point raster.  311 

Floating point raster layers cannot be converted to polygon features.  If a final polygon feature (e.g. vUTRI) is 312 

needed (e.g. for reporting) then it must first be converted to an integer raster layer.   313 

The example above uses the Int() function to convert the final summation to an integer raster during the one pass 314 

through the raster calculator.  The constant 0.5 is added to each floating point raster cell value from the main 315 

calculation to force rounding (as opposed to truncation).   316 

Alternatively, if weighting factors are only required to be whole numbers (e.g. 1, 2,3) then using them without a 317 

decimal (e.g. 1.0) will create an integer raster as needed. 318 

And finally, if the floating point raster is to be reclassified, the conversion to integer can occur at that time. 319 


